有助于对IGP协议(OSPF)和BGP协议加深掌握,产业界建议对互联网展开分域自治的想想

BGP优选AS号短的门道作为首选路由的表达结果

IGP和BGP路由协和式飞机合作下落非主题路由器的路由容积的试验与总括

IGP和BGP路由协和式飞机合营降低非主题路由器的路由容积的试验与总计

 

一、结论

  通过eBGP合计,能够显著下降对非大旨路由器的路由体量须要,因为基本路由器的数额明显少于非主旨路由器,所以,通过此形式既能够连接网络,又下降路由器的硬件设备需求,十三分体面大型网络架构划设想计。

一、结论

  通过eBGP商讨,能够分明降低对非宗旨路由器的路由体量须要,因为基本路由器的多寡肯定少于非主旨路由器,所以,通过此方法既能够连接网络,又降低路由器的硬件设施须求,相当方便大型互连网架构划设想计。

1、结论:

2、背景介绍

  一、随着互联网范围变大,路由器的路由表体量也供给变大,为了应对该难题,产业界提议对网络开始展览分域自治的想想,自治域内运维IGP协议,自治域间运营BGP协议。

  二、常用的IGP协议是OSPF,BGP协议正是BGP-肆(version 肆).

2、背景介绍

  1、随着网络规模变大,路由器的路由表体积也亟需变大,为了应对该难题,产业界建议对互联网展开分域自治的想想,自治域内运维IGP协议,自治域间运营BGP协议。

  贰、常用的IGP协议是OSPF,BGP协议正是BGP-4(version 4).

(一)EBGP会优选AS号少的门路作为转载路径,当优选路径失效时,再选用次选路由。

三、本文的含义

  本文使用了eNSP软件工具举行建立模型,模拟五个自治域之间,通过BGP-四协议进行互通互联,自治域内部使用OSPF实行互联互通的场景,通过对本文的开卷和理解,有助于对IGP协议(OSPF)和BGP协议加深领会。

三、本文的意思

  本文使用了eNSP软件工具进行建模,模拟几个自治域之间,通过BGP-肆协议进行互通互联,自治域内部接纳OSPF进行互联互通的现象,通过对本文的阅读和通晓,有助于对IGP协议(OSPF)和BGP协议加深驾驭。

(2)EBGP邻居建立在直连设备之间。

四、互联网组网和布置

一、互联网组网图和接口ip配置,如下图。

图片 1

 

  说明:

  (1)
为了下跌互连网复杂度,网络采纳分域的笔触组建,全网分为3个自治域,第一个自治域内有3台路由器(QX56一,
中华V二, PAJERO三) ,AS号为6500八 ,第三个自治域内有三台路由器(Koleos四,奥迪Q7伍,Koleos陆),AS号为
6500九,第拾个自治域内有二台路由器(PE一,PE二),AS号为65100。第伍个自治域连接八个独立的自治域,所以中级的路由器又称作宗旨路由器。

别的,PRADO三、PE一、PE二、Sportage四是自治域的分界路由器。

  (2)
自治域内运维OSPF协议,PE一和PE2属于同1自治域,所以中间运转iBGP协议,福睿斯叁和PE1之间,以及PE2和君越四属于不相同自治域,所以里面运营eBGP协议。

 

二、第三个自治域AS65008内的IGP配置如下:

  Sportage1、揽胜极光二、ENCORE3运行OSPF协议,并且奥德赛叁作为边界路由器,在全方位自治域内布告私下认可路由。

  本田CR-V一上的铺排如下:

#
ospf 1
area 0.0.0.0
network 1.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
#

LX570二上的布局如下:

#
ospf 1
area 0.0.0.0
network 2.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#

昂Cora3上的配置如下:

#
ospf 1
default-route-advertise                                           —->解释:
自治域内公告私下认可路由的第三步,通过OSPF文告出来。
area 0.0.0.0
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 30.0.0.二                     —->解释: 自治域内通知暗许路由的第二步,本身先配备私下认可路由。
#

三、第二个自治域AS65009内的IGP配置如下,并且福特Explorer四作为边界路由器,在任何自治域内公告默许路由。

  福特Explorer肆、凯雷德5、福特Explorer陆运维OSPF协议,并且Murano四作为边界路由器,在全路自治域内文告默许路由。

  Tucson四上的安顿如下:   

#
ospf 1
default-route-advertise                       —->解释: 自治域内通知默许路由
area 0.0.0.0
network 40.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 70.0.0.1
#

RAV45上的布署如下:

#
ospf 1
area 0.0.0.0
network 4.0.0.0 0.0.0.255
network 40.0.0.0 0.0.0.255
#

  Escort6上配备如下:

#
ospf 1
area 0.0.0.0
network 5.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#

四、第三个自治域AS65100的七个PE上不须要周转OSPF协议,只须要周转BGP协议,iBGP和eBGP是一起安顿的,如下:

       PE1的配置:

#
bgp 65100
router-id 172.0.60.1
peer 30.0.0.1 as-number 65008      —>
解释:eBGP配置
peer 60.0.0.2 as-number 65100      —>
解释:iBGP配置
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0
network 60.0.0.0 255.255.255.0
peer 30.0.0.1 enable
peer 60.0.0.2 enable
#

       PE二的陈设如下:

#
bgp 65100
router-id 172.0.60.2
peer 60.0.0.1 as-number 65100             
peer 70.0.0.2 as-number 65009
#
ipv4-family unicast
undo synchronization
network 60.0.0.0 255.255.255.0
network 70.0.0.0 255.255.255.0
peer 60.0.0.1 enable
peer 70.0.0.2 enable
#

 5、CRUISER叁和中华V四作为自治域的界线路由器,其上运营BGP协议,配置如下:

       帕杰罗三计划如下:   

#
bgp 6500八                               
—> 解释:本自治域号
router-id 17贰.0.30.1                 —> 解释:本自治域号,
router-id标识自身
peer 30.0.0.2 as-number 65拾0    —>
解释:BGP邻居与比邻的AS号,由于邻居的AS号与本域的AS号差别,所以是eBGP
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0   —>
解释:配置BGP引进路由表
import-route ospf 一                     —>
解释:将地面包车型客车ospf路由引入到BGP中,从而让BGP邻居领悟本域的路由音信。
peer 30.0.0.2 enable
#

       悍马H2四的配备如下:

#
bgp 65009
router-id 172.0.70.2
peer 70.0.0.1 as-number 65100
#
ipv4-family unicast
undo synchronization
network 70.0.0.0 255.255.255.0
import-route ospf 1
peer 70.0.0.1 enable
#

四、网络组网和布署

一、互连网组网图和接口ip配置,如下图。

图片 2

 

  说明:

  (一)
为了下降互连网复杂度,互连网使用分域的思路组建,全网分为1个自治域,第2个自治域内有3台路由器(冠道壹,
LAND二, 奥迪Q33) ,AS号为6500八 ,第三个自治域内有3台路由器(凯雷德四,Sportage5,LX570陆),AS号为
65009,第伍个自治域内有二台路由器(PE壹,PE2),AS号为65拾0。第七个自治域连接四个单身的自治域,所以中间的路由器又叫做焦点路由器。

除此以外,中华V叁、PE1、PE二、汉兰达肆是自治域的边界路由器。

  (二)
自治域内运转OSPF协议,PE1和PE贰属于同一自治域,所以里面运转iBGP协议,Odyssey叁和PE一之间,以及PE二和PAJERO4属于差异自治域,所以里面运转eBGP协议。

 

二、第3个自治域AS65008内的IGP配置如下:

  索罗德一、福睿斯二、Odyssey叁运维OSPF协议,并且LX5703作为边界路由器,在方方面面自治域内文告暗中同意路由。

  Rubicon一上的布局如下:

#
ospf 1
area 0.0.0.0
network 1.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
#

PRADO二上的配置如下:

#
ospf 1
area 0.0.0.0
network 2.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#

Murano三上的计划如下:

#
ospf 1
default-route-advertise                                           —->解释:
自治域内文告私下认可路由的第三步,通过OSPF公告出来。
area 0.0.0.0
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 30.0.0.二                     —->解释: 自治域内通知暗许路由的首先步,自身先安排默许路由。
#

三、第四个自治域AS6500玖内的IGP配置如下,并且PAJERO4作为边界路由器,在任何自治域内布告暗中认可路由。

  Odyssey四、Wrangler伍、LX570陆运营OSPF协议,并且哈弗四作为边界路由器,在全体自治域内通知暗中同意路由。

  XC604上的配置如下:   

#
ospf 1
default-route-advertise                       —->解释: 自治域内文告暗中认可路由
area 0.0.0.0
network 40.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 70.0.0.1
#

瑞鹰五上的安排如下:

#
ospf 1
area 0.0.0.0
network 4.0.0.0 0.0.0.255
network 40.0.0.0 0.0.0.255
#

  宝马X56上安顿如下:

#
ospf 1
area 0.0.0.0
network 5.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#

四、第捌个自治域AS65十0的多少个PE上不供给周转OSPF协议,只必要周转BGP协议,iBGP和eBGP是1起布置的,如下:

       PE1的配置:

#
bgp 65100
router-id 172.0.60.1
peer 30.0.0.1 as-number 65008      —>
解释:eBGP配置
peer 60.0.0.2 as-number 65100      —>
解释:iBGP配置
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0
network 60.0.0.0 255.255.255.0
peer 30.0.0.1 enable
peer 60.0.0.2 enable
#

       PE二的安排如下:

#
bgp 65100
router-id 172.0.60.2
peer 60.0.0.1 as-number 65100             
peer 70.0.0.2 as-number 65009
#
ipv4-family unicast
undo synchronization
network 60.0.0.0 255.255.255.0
network 70.0.0.0 255.255.255.0
peer 60.0.0.1 enable
peer 70.0.0.2 enable
#

 5、ENCORE三和帕杰罗4作为自治域的疆界路由器,其上运转BGP协议,配置如下:

       Qashqai叁安插如下:   

#
bgp 6500八                               
—> 解释:本自治域号
router-id 172.0.30.1                 —> 解释:本自治域号,
router-id标识自身
peer 30.0.0.2 as-number 65100    —>
解释:BGP邻居与街坊的AS号,由于邻居的AS号与本域的AS号不相同,所以是eBGP
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0   —>
解释:配置BGP引进路由表
import-route ospf 一                     —>
解释:将地面包车型大巴ospf路由引进到BGP中,从而让BGP邻居精通本域的路由音讯。
peer 30.0.0.2 enable
#

       奥迪Q7四的布署如下:

#
bgp 65009
router-id 172.0.70.2
peer 70.0.0.1 as-number 65100
#
ipv4-family unicast
undo synchronization
network 70.0.0.0 255.255.255.0
import-route ospf 1
peer 70.0.0.1 enable
#

(三)IBGP邻居能够跨设备建立,此时急需钦点好tcp的源ip和目的ip.
源ip正是connect-interface 的ip, 目标ip正是peer ip。

五、验证结果

一、验证自治域内的路由器上的路由表项。

  (一)查看奇骏1路由器的路由表项,如下,从结果看,都以域内路由,未知目标地都走暗许路由。

<Huawei>dis ip routing-table

五、验证结果

1、验证自治域内的路由器上的路由表项。

  (1)查看福睿斯一路由器的路由表项,如下,从结果看,都是域内路由,未知目标地都走私下认可路由。

<Huawei>dis ip routing-table

(四)由于OSPF的路由优先级比EBGP高,所以,为了验证BGP
AS号短路径的作用,无法将BGP的门径引进到OSPF中。

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 10.0.0.1 GigabitEthernet
0/0/0
1.0.0.0/24 Direct 0 0 D 1.0.0.1 Ethernet0/0/1
1.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
2.0.0.0/24 OSPF 10 3 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.0/24 Direct 0 0 D 10.0.0.2 GigabitEthernet
0/0/0
10.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 OSPF 10 2 D 10.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (2)查看讴歌ZDX2路由器的路由表项,如下,从结果看,都是域内路由,未知目标地都走暗中同意路由。

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 10.0.0.1 GigabitEthernet
0/0/0
1.0.0.0/24 Direct 0 0 D 1.0.0.1 Ethernet0/0/1
1.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
2.0.0.0/24 OSPF 10 3 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.0/24 Direct 0 0 D 10.0.0.2 GigabitEthernet
0/0/0
10.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 OSPF 10 2 D 10.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (二)查看昂Cora贰路由器的路由表项,如下,从结果看,都以域内路由,未知目标地都走私下认可路由。

<Huawei>dis ip routing-table

       
 别的,城域网内部OSPF能够保障各类PE设备之间互通,所以,也不供给把OSPF路由引入到BGP中举办发表。

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 20.0.0.1 GigabitEthernet
0/0/1
1.0.0.0/24 OSPF 10 3 D 20.0.0.1 GigabitEthernet
0/0/1
2.0.0.0/24 Direct 0 0 D 2.0.0.1 Ethernet0/0/1
2.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
10.0.0.0/24 OSPF 10 2 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.0/24 Direct 0 0 D 20.0.0.2 GigabitEthernet
0/0/1
20.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (三)查看昂科雷三路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 20.0.0.1 GigabitEthernet
0/0/1
1.0.0.0/24 OSPF 10 3 D 20.0.0.1 GigabitEthernet
0/0/1
2.0.0.0/24 Direct 0 0 D 2.0.0.1 Ethernet0/0/1
2.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
10.0.0.0/24 OSPF 10 2 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.0/24 Direct 0 0 D 20.0.0.2 GigabitEthernet
0/0/1
20.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (三)查看奥迪Q5三路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

 

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 30.0.0.2 GigabitEthernet
0/0/3
1.0.0.0/二四 OSPF 十 2 D 10.0.0.二 GigabitEthernet     —> 解释:OSPF学习到的都以域内路由。
0/0/0
2.0.0.0/24 OSPF 10 2 D 20.0.0.2 GigabitEthernet
0/0/1
四.0.0.0/二4 EBGP 25伍 0 D 30.0.0.2 GigabitEthernet    —>
解释:EBGP学习到的都以域间路由,从PE一分发过来的。
0/0/3
5.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
10.0.0.0/24 Direct 0 0 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 Direct 0 0 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
30.0.0.0/24 Direct 0 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
50.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
60.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
70.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (④)查看大切诺基四路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 30.0.0.2 GigabitEthernet
0/0/3
一.0.0.0/2四 OSPF 十 贰 D 十.0.0.2 GigabitEthernet     —> 解释:OSPF学习到的都以域内路由。
0/0/0
2.0.0.0/24 OSPF 10 2 D 20.0.0.2 GigabitEthernet
0/0/1
四.0.0.0/贰四 EBGP 25五 0 D 30.0.0.二 GigabitEthernet    —>
解释:EBGP学习到的都以域间路由,从PE1分发过来的。
0/0/3
5.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
10.0.0.0/24 Direct 0 0 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 Direct 0 0 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
30.0.0.0/24 Direct 0 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
50.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
60.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
70.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (4)查看Haval四路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

2、组网图:

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 70.0.0.1 GigabitEthernet
0/0/2
1.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
2.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
4.0.0.0/24 OSPF 10 2 D 40.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 OSPF 10 2 D 50.0.0.2 GigabitEthernet
0/0/1
10.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
20.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
30.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
40.0.0.0/24 Direct 0 0 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 Direct 0 0 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
60.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.0/24 Direct 0 0 D 70.0.0.2 GigabitEthernet
0/0/2
70.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (五)查看翼虎5路由器的路由表项,如下,从结果看,都以域内路由,未知指标地都走默许路由。

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 70.0.0.1 GigabitEthernet
0/0/2
1.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
2.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
4.0.0.0/24 OSPF 10 2 D 40.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 OSPF 10 2 D 50.0.0.2 GigabitEthernet
0/0/1
10.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
20.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
30.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
40.0.0.0/24 Direct 0 0 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 Direct 0 0 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
60.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.0/24 Direct 0 0 D 70.0.0.2 GigabitEthernet
0/0/2
70.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (伍)查看卡宴伍路由器的路由表项,如下,从结果看,都以域内路由,未知指标地都走默许路由。

<Huawei>dis ip routing-table

图片 3

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 40.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 Direct 0 0 D 4.0.0.1 Ethernet0/0/1
4.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
5.0.0.0/24 OSPF 10 3 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 Direct 0 0 D 40.0.0.2 GigabitEthernet
0/0/0
40.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 OSPF 10 2 D 40.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (6)查看Wrangler6路由器的路由表项,如下,从结果看,都是域内路由,未知指标地都走暗许路由。

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 40.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 Direct 0 0 D 4.0.0.1 Ethernet0/0/1
4.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
5.0.0.0/24 OSPF 10 3 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 Direct 0 0 D 40.0.0.2 GigabitEthernet
0/0/0
40.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 OSPF 10 2 D 40.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (6)查看凯雷德陆路由器的路由表项,如下,从结果看,都以域内路由,未知指标地都走暗中认可路由。

<Huawei>dis ip routing-table

 

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 50.0.0.1 GigabitEthernet
0/0/1
4.0.0.0/24 OSPF 10 3 D 50.0.0.1 GigabitEthernet
0/0/1
5.0.0.0/24 Direct 0 0 D 5.0.0.1 Ethernet0/0/1
5.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
40.0.0.0/24 OSPF 10 2 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.0/24 Direct 0 0 D 50.0.0.2 GigabitEthernet
0/0/1
50.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

2、验证自治域间的路由器PE一和PE2学习到的路由表项。

  (壹)查看PE一上路由表项如下,因为PE一上唯有BGP协议,所以读书到的路由都以BGP类型的,分为从瑞鹰三读书到的eBGP类型和从PE二学习到的iBGP类型:

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 50.0.0.1 GigabitEthernet
0/0/1
4.0.0.0/24 OSPF 10 3 D 50.0.0.1 GigabitEthernet
0/0/1
5.0.0.0/24 Direct 0 0 D 5.0.0.1 Ethernet0/0/1
5.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
40.0.0.0/24 OSPF 10 2 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.0/24 Direct 0 0 D 50.0.0.2 GigabitEthernet
0/0/1
50.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

二、验证自治域间的路由器PE一和PE2学习到的路由表项。

  (1)查看PE一上路由表项如下,因为PE一上唯有BGP协议,所以读书到的路由都是BGP类型的,分为从福特Explorer叁读书到的eBGP类型和从PE2学习到的iBGP类型:

<Huawei>dis ip routing-table

三、验证结果

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
2.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
4.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
10.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
20.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.0/24 Direct 0 0 D 30.0.0.2 GigabitEthernet
0/0/3
30.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
50.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
60.0.0.0/24 Direct 0 0 D 60.0.0.1 GigabitEthernet
0/0/0
60.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 IBGP 255 0 RD 60.0.0.2 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (二)查看PE二上的路由表项如下,
从结果看同PE一学习到的路由类似,凡是从R4学学到的都以eBGP类型,从PE一学习到的都以IBGP类型,如下:

<Huawei>display ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
2.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
4.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
10.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
20.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.0/24 Direct 0 0 D 30.0.0.2 GigabitEthernet
0/0/3
30.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
50.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
60.0.0.0/24 Direct 0 0 D 60.0.0.1 GigabitEthernet
0/0/0
60.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 IBGP 255 0 RD 60.0.0.2 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (二)查看PE2上的路由表项如下,
从结果看同PE1学习到的路由类似,凡是从PAJERO四读书到的都以eBGP类型,从PE一学习到的都以IBGP类型,如下:

<Huawei>display ip routing-table

(一)日常意况下,从PC3 —> PC一 的路由,走CE二 —> CE 一 —> PE
1 —> PE三  —-> CE3

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
2.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
5.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
10.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
30.0.0.0/24 IBGP 255 0 RD 60.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
50.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
60.0.0.0/24 Direct 0 0 D 60.0.0.2 GigabitEthernet
0/0/0
60.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 Direct 0 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

3、互联网连通性验证

  (一)从PC一 分别ping
PC二,PC三,PC4,结果显示都可以ping通,表达整网是路由可到的。

PC>ping 4.0.0.10 -c 2

Ping 4.0.0.10: 32 data bytes, Press Ctrl_C to break
From 4.0.0.10: bytes=32 seq=1 ttl=122 time=265 ms
From 4.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 4.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/257/265 ms

PC>ping 2.0.0.10 -c 2

Ping 2.0.0.10: 32 data bytes, Press Ctrl_C to break
From 2.0.0.10: bytes=32 seq=1 ttl=125 time=109 ms
From 2.0.0.10: bytes=32 seq=2 ttl=125 time=141 ms

— 2.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 109/125/141 ms

PC>ping 5.0.0.10 -c 2

Ping 5.0.0.10: 32 data bytes, Press Ctrl_C to break
From 5.0.0.10: bytes=32 seq=1 ttl=122 time=282 ms
From 5.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 5.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/266/282 ms

PC>

  

  (2)从PC壹上tracerout PC二, PC叁,PC四,
可知沿途的路由器是未可厚非的,当然,不科学的话,网络就短路了。

PC>tracert 4.0.0.10

traceroute to 4.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 47 ms 31 ms 32 ms
2 10.0.0.1 62 ms 94 ms 47 ms
3 30.0.0.2 93 ms 94 ms 94 ms
4 60.0.0.2 109 ms 125 ms 125 ms
5 70.0.0.2 172 ms 219 ms 172 ms
6 40.0.0.2 219 ms 250 ms 234 ms
7 *4.0.0.10 234 ms 203 ms

PC>

PC>tracert 2.0.0.10

traceroute to 2.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 32 ms 31 ms 31 ms
2 10.0.0.1 94 ms 78 ms 63 ms
3 20.0.0.2 125 ms 125 ms 109 ms
4 *2.0.0.10 171 ms 157 ms

PC>

PC>tracert 5.0.0.10

traceroute to 5.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 31 ms 31 ms 31 ms
2 10.0.0.1 63 ms 62 ms 63 ms
3 30.0.0.2 94 ms 78 ms 94 ms
4 60.0.0.2 125 ms 125 ms 125 ms
5 70.0.0.2 187 ms 172 ms 156 ms
6 50.0.0.2 188 ms 203 ms 172 ms
7 *5.0.0.10 312 ms 313 ms

PC>

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
2.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
5.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
10.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
30.0.0.0/24 IBGP 255 0 RD 60.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
50.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
60.0.0.0/24 Direct 0 0 D 60.0.0.2 GigabitEthernet
0/0/0
60.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 Direct 0 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

三、互联网连通性验证

  (壹)从PC一 分别ping
PC二,PC叁,PC四,结果突显都足以ping通,表达整网是路由可到的。

PC>ping 4.0.0.10 -c 2

Ping 4.0.0.10: 32 data bytes, Press Ctrl_C to break
From 4.0.0.10: bytes=32 seq=1 ttl=122 time=265 ms
From 4.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 4.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/257/265 ms

PC>ping 2.0.0.10 -c 2

Ping 2.0.0.10: 32 data bytes, Press Ctrl_C to break
From 2.0.0.10: bytes=32 seq=1 ttl=125 time=109 ms
From 2.0.0.10: bytes=32 seq=2 ttl=125 time=141 ms

— 2.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 109/125/141 ms

PC>ping 5.0.0.10 -c 2

Ping 5.0.0.10: 32 data bytes, Press Ctrl_C to break
From 5.0.0.10: bytes=32 seq=1 ttl=122 time=282 ms
From 5.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 5.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/266/282 ms

PC>

  

  (二)从PC一上tracerout PC二, PC三,PC四,
可知沿途的路由器是天经地义的,当然,不科学的话,网络就打断了。

PC>tracert 4.0.0.10

traceroute to 4.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 47 ms 31 ms 32 ms
2 10.0.0.1 62 ms 94 ms 47 ms
3 30.0.0.2 93 ms 94 ms 94 ms
4 60.0.0.2 109 ms 125 ms 125 ms
5 70.0.0.2 172 ms 219 ms 172 ms
6 40.0.0.2 219 ms 250 ms 234 ms
7 *4.0.0.10 234 ms 203 ms

PC>

PC>tracert 2.0.0.10

traceroute to 2.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 32 ms 31 ms 31 ms
2 10.0.0.1 94 ms 78 ms 63 ms
3 20.0.0.2 125 ms 125 ms 109 ms
4 *2.0.0.10 171 ms 157 ms

PC>

PC>tracert 5.0.0.10

traceroute to 5.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 31 ms 31 ms 31 ms
2 10.0.0.1 63 ms 62 ms 63 ms
3 30.0.0.2 94 ms 78 ms 94 ms
4 60.0.0.2 125 ms 125 ms 125 ms
5 70.0.0.2 187 ms 172 ms 156 ms
6 50.0.0.2 188 ms 203 ms 172 ms
7 *5.0.0.10 312 ms 313 ms

PC>

从PC三上查看路由:

六、总结

壹、分域使用这么些措施完毕了下跌非大旨路由器的路由表容积的渴求?

  解答:共使用3种措施,

  第1、分域,域内使用OSPF,域间使用BGP。

  第一、域内通过OPF通告的默许路由,使得域内的路由器不须求了然别的域的路由消息,只供给经过暗中认可路由,送给PE设备即可。

  第三、域间的主旨层使用eBGP知晓全部的明细路由,以便教导域间流量转发。

二、遗留难点,怎么样布署让IGP的疆界路由器的路由表体量也变小?

  宝马X3三、卡宴四作为七个自治域的分界路由器,通过eBGP知道了颇具的网络路由,那几个对路由器的渴求照旧非常大,有哪些艺术能够让那五个路由器只必要将不可能转正的报文通过暗中认可路由转载即可。继续探索中

3、BGP的基本用途是怎样?

  解答:主旨层设备接头全量路由,指引报文在域间转载。

 

六、总结

1、分域使用那一个措施完结了下跌非宗旨路由器的路由表体量的渴求?

  解答:共使用3种措施,

  第一、分域,域内使用OSPF,域间使用BGP。

  第叁、域内通过OPF公告的暗中同意路由,使得域内的路由器不供给通晓其余域的路由音信,只须求通过暗许路由,送给PE设备即可。

  第一、域间的宗旨层使用eBGP知晓全数的明细路由,以便教导域间流量转载。

2、遗留难点,怎么样安插让IGP的界限路由器的路由表体积也变小?

  Sportage三、奇骏4作为多个自治域的界线路由器,通过eBGP知道了有着的网络路由,那几个对路由器的渴求还是相当大,有哪些点子能够让那三个路由器只须求将不可能转正的报文通过暗许路由转载即可。继续深究中

三、BGP的中坚用途是何许?

  解答:大旨层设备接头全量路由,辅导报文在域间转载。

 

PC>tracert 192.168.0.10

traceroute to 192.168.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 172.16.0.1 32 ms 15 ms 16 ms
2 100.0.0.2 47 ms 47 ms 62 ms
3 60.0.0.1 63 ms 78 ms 62 ms
4 40.0.0.2 125 ms 78 ms 94 ms
5 10.0.0.1 94 ms 109 ms 110 ms
6 192.168.0.10 156 ms 125 ms 156 ms

PC>

 

翻开此时CE二上路由音讯,可知下一跳是CE之间的IBGP路径。

图片 4

 

 

(2)优选路由故障景况下,走次选路由。从PC叁 —> PC1 的路由,走CE二—> PE二 —> PE 4 —> 汉兰达壹 —> PE三  —-> CE三

情势链路故障:PE壹 设施上关闭端口GE 0/0/三(ip地址为 40.0.0.一).

从PC3上查看路由:

PC>tracert 192.168.0.10

traceroute to 192.168.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 172.16.0.1 16 ms 15 ms 32 ms
2 70.0.0.1 31 ms 47 ms 47 ms
3 50.0.0.1 62 ms 63 ms 78 ms
4 30.0.0.1 109 ms 63 ms 93 ms
5 20.0.0.2 125 ms 94 ms 156 ms
6 10.0.0.1 157 ms 140 ms 157 ms
7 192.168.0.10 156 ms 172 ms 187 ms

PC>

 

翻看此时CE2上路由音信,可知下一跳是PE二之间的EBGP路径。

图片 5

 

(三)故障恢复生机后,路由回切到优选路由。

结果见(1) 

 

肆、曾经现身的难点

(1)PE二和PE三之间,建立EBGP对等体失利。

缘由:EBGP邻居只可以建立在直连设备间,无法跨设备建立EBGP邻居。

就此,先通过PE四和PE3建立IBGP对等体,然后在经过PE四和PE2建立EBGP对等体,从而将PE三上的路由新闻告知PE2。

 

(2)直连的设施不可能树立IBGP邻居。

由来:1般意况下,大家会选取loopback ip作为BGP 的router id.
此时要注意,建立邻居时使用的peer 地址和这一个router id未有关联,此时peer
ip应当设置成直连设备之间的ip即可。

bgp 65001
router-id 60.0.0.1
peer 40.0.0.2 as-number 65001

 

(3)非直连的设备之间不能够树立IBGP邻居。

难点现象:查看bgp
peer的境况,总是停在active状态,不可能到达established状态。从BGP邻居的1端
ping 另

难题源于:BGP邻居的树立信赖于TCP可达,非直连的街坊必须铺排相同的TCP源ip和指标ip,才能创建。源ip便是connect-interface
的ip, 目标ip正是peer ip。

以PE3、PE4为例,

PE3的布局如下:

bgp 65001
router-id 10.0.0.2
peer 30.0.0.2 as-number 65001
peer 30.0.0.2 connect-interface GigabitEthernet0/0/0     (说明: GigabitEthernet0/0/0 的ip地址=
20.0.0.2)

 

PE四的配置如下:

bgp 65001
router-id 50.0.0.1
peer 20.0.0.2 as-number 65001
peer 20.0.0.2 connect-interface GigabitEthernet0/0/1  (说明: GigabitEthernet0/0/1
的ip地址= 30.0.0.2)

(4)OSPF学习的路由优先级比BGP高,导致首要选取路由连接被OSPF协议优选。

现已出现的场景,PE2、PE叁准将BGP的路由引入到OSPF中,结果造成在PE一上查看
17贰.1陆.0.10 的路由下壹跳为40.0.0.2,
而根据BGP短的AS号路径的语气,下一跳应当是60.0.0.二.
停歇PE2、PE3上BGP的路子引进BGP后,PE一上目标17二.1六.0.拾的下一跳符合预期。

安分守己设备手册上的叙述:个中,0意味一向连接的路由,25五表示别的来自不可信赖源端的路由;数值越小表明优先级越高。

图片 6

 

 

5、常用命令和调剂命令。

(一)怎么看出来有两条BGP路由,优选了AS号短的门道?

关键设备是CE二,可能CE1设备,查看那七个装备的bgp路由,能够看出有两条到达相同指标ip的路由,以CE二为例,

<CE2>dis bgp routing-table 192.168.0.10

BGP local router ID : 70.0.0.2
Local AS number : 65009
Paths: 2 available, 1 best, 1
select

BGP routing table entry information of 192.168.0.0/24:
From: 100.0.0.2 (60.0.0.2)
Route Duration: 00h12m53s 
Relay IP Nexthop: 100.0.0.2
Relay IP Out-Interface: Vlanif3
Original nexthop: 60.0.0.1
Qos information : 0x0
AS-path 65001 65005, origin igp,
localpref 100, pref-val 0, valid, internal, be

st, select, active, pre 255
Advertised to such 1 peers:
70.0.0.1
BGP routing table entry information of 192.168.0.0/24:
From: 70.0.0.1 (70.0.0.1)
Route Duration: 00h12m26s 
Direct Out-interface: Vlanif2
Original nexthop: 70.0.0.1
Qos information : 0x0
AS-path 65002 65001 65005, origin igp, pref-val 0, valid, external, pre
255, no
t preferred for AS-Path
Not advertised to any peer yet

<CE2>

 

(二)展现钦赐项目的协商学习的路由

<PE2>dis ip routing-table protocol ospf

Route Flags: R – relay, D – download to fib

Public routing table : OSPF
Destinations : 5 Routes : 5

OSPF routing table status : <Active>
Destinations : 5 Routes : 5

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.0.0/24 OSPF 10 4 D 50.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 OSPF 10 3 D 50.0.0.1 GigabitEthernet
0/0/0
30.0.0.0/24 OSPF 10 2 D 50.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 OSPF 10 4 D 50.0.0.1 GigabitEthernet
0/0/0
60.0.0.0/24 OSPF 10 5 D 50.0.0.1 GigabitEthernet
0/0/0

OSPF routing table status : <Inactive>
Destinations : 0 Routes : 0

<PE2>

<PE2>dis ip routing-table protocol bgp

Route Flags: R – relay, D – download to fib

Public routing table : BGP
Destinations : 5 Routes : 5

BGP routing table status : <Active>
Destinations : 5 Routes : 5

Destination/Mask Proto Pre Cost Flags NextHop Interface

3.0.0.2/32 EBGP 255 0 D 50.0.0.1 GigabitEthernet
0/0/0
100.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
172.16.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
172.16.1.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
192.168.0.0/24 EBGP 255 0 D 50.0.0.1 GigabitEthernet
0/0/0

BGP routing table status : <Inactive>
Destinations : 0 Routes : 0

<PE2>

 

(三)展现BGP邻居信息

<PE2>dis bgp peer

BGP local router ID : 70.0.0.1
Local AS number : 65002
Total number of peers : 2 Peers in established state : 2

Peer V AS MsgRcvd MsgSent OutQ Up/Down State Pre
fRcv

50.0.0.1 4 65001 183 315 0 02:26:04 Established
7
70.0.0.2 4 65009 161 187 0 01:21:57 Established
10
<PE2>

 

(四)展现BGP路由详细消息

 

<PE2>dis bgp routing-table

图片 7

图片 8

 

(5)显示 路由表,展现内定目标ip的路由音讯。

<CE2>dis ip routing-table 

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

3.0.0.2/32 IBGP 255 0 RD 60.0.0.1 Vlanif3
10.0.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3
20.0.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3
30.0.0.0/24 EBGP 255 2 D 70.0.0.1 Vlanif2
40.0.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3
50.0.0.0/24 EBGP 255 0 D 70.0.0.1 Vlanif2
60.0.0.0/24 IBGP 255 0 RD 100.0.0.2 Vlanif3
70.0.0.0/24 Direct 0 0 D 70.0.0.2 Vlanif2
70.0.0.2/32 Direct 0 0 D 127.0.0.1 Vlanif2
100.0.0.0/24 Direct 0 0 D 100.0.0.1 Vlanif3
100.0.0.1/32 Direct 0 0 D 127.0.0.1 Vlanif3
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
172.16.0.0/24 Direct 0 0 D 172.16.0.1 Vlanif1
172.16.0.1/32 Direct 0 0 D 127.0.0.1 Vlanif1
172.16.1.0/24 IBGP 255 0 RD 100.0.0.2 Vlanif3
192.168.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3

<CE2>

 

呈现钦命目标ip的优选路由

<CE2>dis ip routing-table 192.168.0.10 

Route Flags: R – relay, D – download to fib

Routing Table : Public
Summary Count : 1
Destination/Mask Proto Pre Cost Flags NextHop Interface

192.168.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3

<CE2>

 

 

(伍)定位BGP无法建立的通令

<PE2>debug bgp 50.0.0.1 all
<PE2>t d
Info: Current terminal debugging is on.
<PE2>t m
Info: Current terminal monitor is on.
<PE2>sys
Enter system view, return user view with Ctrl+Z.
[PE2]info enable
Info: Information center is enabled.
[PE2]

 

 6、关键配置

CE3设备配备:

#
bgp 65005
router-id 10.0.0.1
peer 十.0.0.二 as-number 65001              (与营业商PE之间确立 EBGP
邻居)
#
ipv4-family unicast
undo synchronization
network 10.0.0.0 255.255.255.0
network 192.168.0.0
peer 10.0.0.2 enable
#

 

PE三设备配置:

#
bgp 65001
router-id 10.0.0.2
peer 10.0.0.1 as-number 6500伍                                 
 (与客户CE之间确立 EBGP 邻居)
peer 20.0.0.一 as-number 6500一                                 
 (与营业商PE之间建立 IBGP 邻居)
peer 30.0.0.2 as-number 65001
peer 30.0.0.2 connect-interface GigabitEthernet0/0/0
peer 40.0.0.1 as-number 65001
peer 50.0.0.二 as-number 6500二                                  (与营业商PE之间确立 EBGP 邻居)
peer 50.0.0.2 connect-interface GigabitEthernet0/0/1
#
ipv4-family unicast
undo synchronization
network 3.0.0.1 255.255.255.255
network 10.0.0.0 255.255.255.0
network 20.0.0.0 255.255.255.0
network 40.0.0.0 255.255.255.0
peer 10.0.0.1 enable
peer 20.0.0.1 enable
peer 30.0.0.2 enable
peer 40.0.0.1 enable
peer 50.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
network 40.0.0.0 0.0.0.255
#

 

GL450一设备配备:

#
bgp 65001
router-id 20.0.0.1
peer 10.0.0.2 as-number 65001
peer 30.0.0.2 as-number 65001
peer 50.0.0.2 as-number 65001
peer 50.0.0.2 connect-interface GigabitEthernet0/0/0
#
ipv4-family unicast
undo synchronization
network 20.0.0.0 255.255.255.0
network 30.0.0.0 255.255.255.0
peer 10.0.0.2 enable
peer 30.0.0.2 enable
peer 50.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 20.0.0.0 0.0.0.255
network 30.0.0.0 0.0.0.255
#

 

PE四设备配置:

#
bgp 65001
router-id 50.0.0.1
peer 20.0.0.二 as-number 6500一          (与运维商PE之间建立 IBGP 邻居)
peer 20.0.0.2 connect-interface GigabitEthernet0/0/1
peer 30.0.0.1 as-number 6500一          (与运维商PE之间建立 IBGP 邻居)
peer 50.0.0.贰 as-number 65002          (与营业商PE之间创设 EBGP 邻居)
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0
network 50.0.0.0 255.255.255.0
peer 20.0.0.2 enable
peer 30.0.0.1 enable
peer 50.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 30.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#

 

PE2设备配备:

#
bgp 65002
router-id 70.0.0.1
peer 50.0.0.一 as-number 65001             (与运行商PE之间建立 IBGP 邻居)
peer 70.0.0.2 as-number 6500玖             (与客户CE之间建立 EBGP 邻居)
#
ipv4-family unicast
undo synchronization
network 50.0.0.0 255.255.255.0
network 70.0.0.0 255.255.255.0
peer 50.0.0.1 enable
peer 70.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 50.0.0.0 0.0.0.255
network 70.0.0.0 0.0.0.255
#

 

CE二设备配备:

#
bgp 65009
router-id 70.0.0.2
peer 70.0.0.1 as-number 65002              (与营业商PE之间确立EBGP邻居)
peer 100.0.0.二 as-number 6500九           
(与同级设备建立IBGP邻居)
#
ipv4-family unicast
undo synchronization
network 70.0.0.0 255.255.255.0
network 100.0.0.0 255.255.255.0
network 172.16.0.0 255.255.255.0
peer 70.0.0.1 enable
peer 100.0.0.2 enable
#

 

PE1设备配备:

#
bgp 65001
router-id 60.0.0.1
peer 40.0.0.二 as-number 6500一           (与营业商PE之间创造 IBGP 邻居)
peer 60.0.0.二 as-number 6500九           (与客户CE之间确立 EBGP 邻居)
#
ipv4-family unicast
undo synchronization
network 40.0.0.0 255.255.255.0
network 60.0.0.0 255.255.255.0
peer 40.0.0.2 enable
peer 60.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 40.0.0.0 0.0.0.255
network 60.0.0.0 0.0.0.255
#

 

CE壹设备配置:

#
bgp 65009
router-id 60.0.0.2
peer 60.0.0.壹 as-number 65001                (与营业商PE之间创立EBGP邻居)
peer 十0.0.0.1 as-number 6500玖             
(与同级设备建立IBGP邻居)
#
ipv4-family unicast
undo synchronization
network 60.0.0.0 255.255.255.0
network 172.16.1.0 255.255.255.0
peer 60.0.0.1 enable
peer 100.0.0.1 enable
#

相关文章