ca88亚洲城网站产业界建议对网络展开分域自治的挂念,(一)EBGP会优选AS号少的路径作为转载路径

IGP和BGP路由协和式飞机协作降低非大旨路由器的路由体量的尝试与总计

IGP和BGP路由协和式飞机合营下跌非大旨路由器的路由容积的尝试与总括

BGP优选AS号短的门道作为首要采用路由的辨证结果

一、结论

  通过eBGP协和式飞机,能够显著下跌对非大旨路由器的路由容积要求,因为基本路由器的数量肯定少于非宗旨路由器,所以,通过此方法既能够连接网络,又下落路由器的硬件装备要求,十二分方便大型网络架构划设想计。

一、结论

  通过eBGP协和式飞机,能够一目精通下落对非大旨路由器的路由体量要求,因为基本路由器的数额显然少于非主旨路由器,所以,通过此措施既可以连接网络,又降低路由器的硬件装备供给,格外适用大型网络架构划设想计。

 

贰、背景介绍

  一、随着互联网范围变大,路由器的路由表容积也供给变大,为了应对该难题,产业界建议对互连网开始展览分域自治的思量,自治域内运维IGP协议,自治域间运维BGP协议。

  贰、常用的IGP协议是OSPF,BGP协议正是BGP-4(version 4).

贰、背景介绍

  一、随着网络规模变大,路由器的路由表容积也亟需变大,为了应对该难点,产业界提议对互联网展开分域自治的思考,自治域内运维IGP协议,自治域间运维BGP协议。

  二、常用的IGP协议是OSPF,BGP协议正是BGP-四(version 四).

1、结论:

3、本文的意义

  本文使用了eNSP软件工具进行建立模型,模拟三个自治域之间,通过BGP-四协议举行互通互联,自治域内部使用OSPF进行互联互通的地方,通过对本文的阅读和精通,有助于对IGP协议(OSPF)和BGP协议加深明白。

3、本文的意义

  本文使用了eNSP软件工具举行建立模型,模拟五个自治域之间,通过BGP-四协议实行互通互联,自治域内部使用OSPF举办互联互通的景色,通过对本文的翻阅和驾驭,有助于对IGP协议(OSPF)和BGP协议加深领悟。

(一)EBGP会优选AS号少的门道作为转载路径,当优选路径失效时,再选用次选路由。

四、网络组网和配备

一、互连网组网图和接口ip配置,如下图。

ca88亚洲城网站 1

 

  说明:

  (壹)
为了下跌互连网复杂度,互连网利用分域的思绪组建,全网分为2个自治域,第1个自治域内有三台路由器(奥迪Q3一,
奥德赛二, 纳瓦拉三) ,AS号为65008 ,第1个自治域内有三台路由器(RAV44,纳瓦拉5,卡宴陆),AS号为
6500玖,第四个自治域内有二台路由器(PE一,PE二),AS号为65100。第三个自治域连接四个单身的自治域,所以中间的路由器又称之为焦点路由器。

除此以外,福特Explorer三、PE一、PE二、奥迪Q5四是自治域的边界路由器。

  (2)
自治域内运营OSPF协议,PE一和PE2属于同1自治域,所以里面运营iBGP协议,PAJERO叁和PE1之间,以及PE2和普拉多4属于不相同自治域,所以里面运转eBGP协议。

 

二、第一个自治域AS65008内的IGP配置如下:

  中华V一、陆风X8二、奔驰M级三运作OSPF协议,并且PRADO三作为边界路由器,在全部自治域内文告暗中认可路由。

  奇骏一上的安插如下:

#
ospf 1
area 0.0.0.0
network 1.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
#

锐界二上的布局如下:

#
ospf 1
area 0.0.0.0
network 2.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#

XC603上的配置如下:

#
ospf 1
default-route-advertise                                           —->解释:
自治域内文告私下认可路由的第3步,通过OSPF文告出来。
area 0.0.0.0
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 30.0.0.二                     —->解释: 自治域内布告私下认可路由的第3步,本人先配备默许路由。
#

三、第壹个自治域AS6500玖内的IGP配置如下,并且奥迪Q7肆作为边界路由器,在全部自治域内公告默许路由。

  福睿斯四、宝马X35、福睿斯陆运转OSPF协议,并且中华V4作为边界路由器,在整整自治域内文告暗中认可路由。

  奇骏4上的陈设如下:   

#
ospf 1
default-route-advertise                       —->解释: 自治域内通知默许路由
area 0.0.0.0
network 40.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 70.0.0.1
#

LX5705上的布署如下:

#
ospf 1
area 0.0.0.0
network 4.0.0.0 0.0.0.255
network 40.0.0.0 0.0.0.255
#

  锐界陆上配置如下:

#
ospf 1
area 0.0.0.0
network 5.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#

肆、第一个自治域AS65拾0的五个PE上不须求周转OSPF协议,只须求周转BGP协议,iBGP和eBGP是手拉手陈设的,如下:

       PE1的配置:

#
bgp 65100
router-id 172.0.60.1
peer 30.0.0.1 as-number 65008      —>
解释:eBGP配置
peer 60.0.0.2 as-number 65100      —>
解释:iBGP配置
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0
network 60.0.0.0 255.255.255.0
peer 30.0.0.1 enable
peer 60.0.0.2 enable
#

       PE2的安插如下:

#
bgp 65100
router-id 172.0.60.2
peer 60.0.0.1 as-number 65100             
peer 70.0.0.2 as-number 65009
#
ipv4-family unicast
undo synchronization
network 60.0.0.0 255.255.255.0
network 70.0.0.0 255.255.255.0
peer 60.0.0.1 enable
peer 70.0.0.2 enable
#

 五、福睿斯3和奥德赛4作为自治域的边界路由器,其上运转BGP协议,配置如下:

       中华V3安插如下:   

#
bgp 6500八                               
—> 解释:本自治域号
router-id 17二.0.30.1                 —> 解释:本自治域号,
router-id标识自身
peer 30.0.0.二 as-number 65十0    —>
解释:BGP邻居与邻里的AS号,由于邻居的AS号与本域的AS号分化,所以是eBGP
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0   —>
解释:配置BGP引入路由表
import-route ospf 1                     —>
解释:将地点的ospf路由引入到BGP中,从而让BGP邻居知道本域的路由音讯。
peer 30.0.0.2 enable
#

       Tiggo④的安顿如下:

#
bgp 65009
router-id 172.0.70.2
peer 70.0.0.1 as-number 65100
#
ipv4-family unicast
undo synchronization
network 70.0.0.0 255.255.255.0
import-route ospf 1
peer 70.0.0.1 enable
#

肆、互联网组网和布署

壹、互连网组网图和接口ip配置,如下图。

ca88亚洲城网站 2

 

  说明:

  (一)
为了下降网络复杂度,网络采纳分域的笔触组建,全网分为1个自治域,第1个自治域内有叁台路由器(R一,
普拉多二, Tucson3) ,AS号为6500八 ,第一个自治域内有叁台路由器(奥德赛四,R5,大切诺基陆),AS号为
6500玖,第多少个自治域内有贰台路由器(PE1,PE二),AS号为65拾0。第十个自治域连接八个单身的自治域,所以中间的路由器又称之为大旨路由器。

此外,宝马X33、PE一、PE二、奇骏四是自治域的边际路由器。

  (二)
自治域内运行OSPF协议,PE一和PE二属于同壹自治域,所以里面运转iBGP协议,Odyssey叁和PE1之间,以及PE二和凯雷德四属于差异自治域,所以里面运维eBGP协议。

 

二、第二个自治域AS65008内的IGP配置如下:

  LX570一、Escort二、卡宴三运作OSPF协议,并且福睿斯三作为边界路由器,在任何自治域内布告暗中认可路由。

  奥迪Q5一上的配备如下:

#
ospf 1
area 0.0.0.0
network 1.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
#

PRADO2上的陈设如下:

#
ospf 1
area 0.0.0.0
network 2.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#

凯雷德三上的计划如下:

#
ospf 1
default-route-advertise                                           —->解释:
自治域内文告暗中同意路由的第二步,通过OSPF公告出来。
area 0.0.0.0
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 30.0.0.贰                     —->解释: 自治域内公告暗中同意路由的率先步,自身先安插私下认可路由。
#

三、第一个自治域AS6500玖内的IGP配置如下,并且科雷傲四作为边界路由器,在总体自治域内通知暗中认可路由。

  R四、GL4505、福睿斯六运营OSPF协议,并且奇骏四作为边界路由器,在方方面面自治域内通知私下认可路由。

  Kuga四上的布局如下:   

#
ospf 1
default-route-advertise                       —->解释: 自治域内布告私下认可路由
area 0.0.0.0
network 40.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 70.0.0.1
#

福睿斯伍上的布局如下:

#
ospf 1
area 0.0.0.0
network 4.0.0.0 0.0.0.255
network 40.0.0.0 0.0.0.255
#

  昂科威6上布署如下:

#
ospf 1
area 0.0.0.0
network 5.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#

四、第三个自治域AS65拾0的七个PE上不要求周转OSPF协议,只需求周转BGP协议,iBGP和eBGP是壹道安顿的,如下:

       PE1的配置:

#
bgp 65100
router-id 172.0.60.1
peer 30.0.0.1 as-number 65008      —>
解释:eBGP配置
peer 60.0.0.2 as-number 65100      —>
解释:iBGP配置
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0
network 60.0.0.0 255.255.255.0
peer 30.0.0.1 enable
peer 60.0.0.2 enable
#

       PE二的安顿如下:

#
bgp 65100
router-id 172.0.60.2
peer 60.0.0.1 as-number 65100             
peer 70.0.0.2 as-number 65009
#
ipv4-family unicast
undo synchronization
network 60.0.0.0 255.255.255.0
network 70.0.0.0 255.255.255.0
peer 60.0.0.1 enable
peer 70.0.0.2 enable
#

 伍、智跑3和智跑四作为自治域的边际路由器,其上运维BGP协议,配置如下:

       揽胜三安顿如下:   

#
bgp 65008                               
—> 解释:本自治域号
router-id 17二.0.30.一                 —> 解释:本自治域号,
router-id标识本身
peer 30.0.0.二 as-number 65十0    —>
解释:BGP邻居与街坊的AS号,由于邻居的AS号与本域的AS号差别,所以是eBGP
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0   —>
解释:配置BGP引入路由表
import-route ospf 一                     —>
解释:将地面包车型地铁ospf路由引入到BGP中,从而让BGP邻居理解本域的路由新闻。
peer 30.0.0.2 enable
#

       Rubicon4的安插如下:

#
bgp 65009
router-id 172.0.70.2
peer 70.0.0.1 as-number 65100
#
ipv4-family unicast
undo synchronization
network 70.0.0.0 255.255.255.0
import-route ospf 1
peer 70.0.0.1 enable
#

(②)EBGP邻居建立在直连设备之间。

五、验证结果

1、验证自治域内的路由器上的路由表项。

  (1)查看奥迪Q5一路由器的路由表项,如下,从结果看,都以域内路由,未知目标地都走私下认可路由。

<Huawei>dis ip routing-table

伍、验证结果

1、验证自治域内的路由器上的路由表项。

  (1)查看Odyssey一路由器的路由表项,如下,从结果看,都以域内路由,未知目标地都走暗中同意路由。

<Huawei>dis ip routing-table

(三)IBGP邻居可以跨设备建立,此时急需钦点好tcp的源ip和目标ip.
源ip正是connect-interface 的ip, 指标ip正是peer ip。

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 10.0.0.1 GigabitEthernet
0/0/0
1.0.0.0/24 Direct 0 0 D 1.0.0.1 Ethernet0/0/1
1.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
2.0.0.0/24 OSPF 10 3 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.0/24 Direct 0 0 D 10.0.0.2 GigabitEthernet
0/0/0
10.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 OSPF 10 2 D 10.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (2)查看卡宴2路由器的路由表项,如下,从结果看,都以域内路由,未知目标地都走默许路由。

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 10.0.0.1 GigabitEthernet
0/0/0
1.0.0.0/24 Direct 0 0 D 1.0.0.1 Ethernet0/0/1
1.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
2.0.0.0/24 OSPF 10 3 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.0/24 Direct 0 0 D 10.0.0.2 GigabitEthernet
0/0/0
10.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 OSPF 10 2 D 10.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (二)查看大切诺基二路由器的路由表项,如下,从结果看,都以域内路由,未知指标地都走暗中认可路由。

<Huawei>dis ip routing-table

(4)由于OSPF的路由优先级比EBGP高,所以,为了验证BGP
AS号短路径的功力,不能够将BGP的不二等秘书诀引入到OSPF中。

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 20.0.0.1 GigabitEthernet
0/0/1
1.0.0.0/24 OSPF 10 3 D 20.0.0.1 GigabitEthernet
0/0/1
2.0.0.0/24 Direct 0 0 D 2.0.0.1 Ethernet0/0/1
2.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
10.0.0.0/24 OSPF 10 2 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.0/24 Direct 0 0 D 20.0.0.2 GigabitEthernet
0/0/1
20.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (叁)查看RAV四三路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 20.0.0.1 GigabitEthernet
0/0/1
1.0.0.0/24 OSPF 10 3 D 20.0.0.1 GigabitEthernet
0/0/1
2.0.0.0/24 Direct 0 0 D 2.0.0.1 Ethernet0/0/1
2.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
10.0.0.0/24 OSPF 10 2 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.0/24 Direct 0 0 D 20.0.0.2 GigabitEthernet
0/0/1
20.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (三)查看奔驰M级三路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

       
 其它,城域网内部OSPF能够保险种种PE设备之间互通,所以,也不必要把OSPF路由引入到BGP中开始展览透露。

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 30.0.0.2 GigabitEthernet
0/0/3
一.0.0.0/二四 OSPF 10 2 D 十.0.0.二 GigabitEthernet     —> 解释:OSPF学习到的都以域内路由。
0/0/0
2.0.0.0/24 OSPF 10 2 D 20.0.0.2 GigabitEthernet
0/0/1
四.0.0.0/二4 EBGP 255 0 D 30.0.0.二 GigabitEthernet    —>
解释:EBGP学习到的都是域间路由,从PE一分发过来的。
0/0/3
5.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
10.0.0.0/24 Direct 0 0 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 Direct 0 0 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
30.0.0.0/24 Direct 0 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
50.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
60.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
70.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (肆)查看索罗德肆路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 30.0.0.2 GigabitEthernet
0/0/3
一.0.0.0/二4 OSPF 10 二 D 10.0.0.二 GigabitEthernet     —> 解释:OSPF学习到的都是域内路由。
0/0/0
2.0.0.0/24 OSPF 10 2 D 20.0.0.2 GigabitEthernet
0/0/1
四.0.0.0/24 EBGP 25伍 0 D 30.0.0.二 GigabitEthernet    —>
解释:EBGP学习到的都以域间路由,从PE壹分发过来的。
0/0/3
5.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
10.0.0.0/24 Direct 0 0 D 10.0.0.1 GigabitEthernet
0/0/0
10.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 Direct 0 0 D 20.0.0.1 GigabitEthernet
0/0/1
20.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
30.0.0.0/24 Direct 0 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
50.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
60.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
70.0.0.0/24 EBGP 255 0 D 30.0.0.2 GigabitEthernet
0/0/3
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (4)查看Highlander四路由器的路由表项,如下,从结果看,有域内OSPF学习到的,也有域间eBGP学习到的:

<Huawei>dis ip routing-table

 

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 70.0.0.1 GigabitEthernet
0/0/2
1.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
2.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
4.0.0.0/24 OSPF 10 2 D 40.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 OSPF 10 2 D 50.0.0.2 GigabitEthernet
0/0/1
10.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
20.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
30.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
40.0.0.0/24 Direct 0 0 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 Direct 0 0 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
60.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.0/24 Direct 0 0 D 70.0.0.2 GigabitEthernet
0/0/2
70.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (伍)查看Koleos伍路由器的路由表项,如下,从结果看,都是域内路由,未知指标地都走私下认可路由。

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 Static 60 0 RD 70.0.0.1 GigabitEthernet
0/0/2
1.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
2.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
4.0.0.0/24 OSPF 10 2 D 40.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 OSPF 10 2 D 50.0.0.2 GigabitEthernet
0/0/1
10.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
20.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
30.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
40.0.0.0/24 Direct 0 0 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 Direct 0 0 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
60.0.0.0/24 EBGP 255 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.0/24 Direct 0 0 D 70.0.0.2 GigabitEthernet
0/0/2
70.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (伍)查看Lacrosse五路由器的路由表项,如下,从结果看,都以域内路由,未知指标地都走暗许路由。

<Huawei>dis ip routing-table

2、组网图:

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 40.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 Direct 0 0 D 4.0.0.1 Ethernet0/0/1
4.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
5.0.0.0/24 OSPF 10 3 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 Direct 0 0 D 40.0.0.2 GigabitEthernet
0/0/0
40.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 OSPF 10 2 D 40.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (陆)查看ENVISION六路由器的路由表项,如下,从结果看,都以域内路由,未知目标地都走暗中同意路由。

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 40.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 Direct 0 0 D 4.0.0.1 Ethernet0/0/1
4.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
5.0.0.0/24 OSPF 10 3 D 40.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 Direct 0 0 D 40.0.0.2 GigabitEthernet
0/0/0
40.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
50.0.0.0/24 OSPF 10 2 D 40.0.0.1 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (陆)查看Haval陆路由器的路由表项,如下,从结果看,都以域内路由,未知指标地都走暗中认可路由。

<Huawei>dis ip routing-table

ca88亚洲城网站 3

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 50.0.0.1 GigabitEthernet
0/0/1
4.0.0.0/24 OSPF 10 3 D 50.0.0.1 GigabitEthernet
0/0/1
5.0.0.0/24 Direct 0 0 D 5.0.0.1 Ethernet0/0/1
5.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
40.0.0.0/24 OSPF 10 2 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.0/24 Direct 0 0 D 50.0.0.2 GigabitEthernet
0/0/1
50.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

二、验证自治域间的路由器PE1和PE2学习到的路由表项。

  (1)查看PE一上路由表项如下,因为PE一上只有BGP协议,所以读书到的路由都是BGP类型的,分为从RAV4三就学到的eBGP类型和从PE贰学习到的iBGP类型:

<Huawei>dis ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 9 Routes : 9

Destination/Mask Proto Pre Cost Flags NextHop Interface

0.0.0.0/0 O_ASE 150 1 D 50.0.0.1 GigabitEthernet
0/0/1
4.0.0.0/24 OSPF 10 3 D 50.0.0.1 GigabitEthernet
0/0/1
5.0.0.0/24 Direct 0 0 D 5.0.0.1 Ethernet0/0/1
5.0.0.1/32 Direct 0 0 D 127.0.0.1 Ethernet0/0/1
40.0.0.0/24 OSPF 10 2 D 50.0.0.1 GigabitEthernet
0/0/1
50.0.0.0/24 Direct 0 0 D 50.0.0.2 GigabitEthernet
0/0/1
50.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

2、验证自治域间的路由器PE一和PE二学习到的路由表项。

  (1)查看PE一上路由表项如下,因为PE一上只有BGP协议,所以读书到的路由都以BGP类型的,分为从PAJERO叁就学到的eBGP类型和从PE贰学习到的iBGP类型:

<Huawei>dis ip routing-table

 

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
2.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
4.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
10.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
20.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.0/24 Direct 0 0 D 30.0.0.2 GigabitEthernet
0/0/3
30.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
50.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
60.0.0.0/24 Direct 0 0 D 60.0.0.1 GigabitEthernet
0/0/0
60.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 IBGP 255 0 RD 60.0.0.2 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (贰)查看PE二上的路由表项如下,
从结果看同PE壹学习到的路由类似,凡是从帕杰罗四学习到的都是eBGP类型,从PE1学习到的都以IBGP类型,如下:

<Huawei>display ip routing-table

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
2.0.0.0/24 EBGP 255 2 D 30.0.0.1 GigabitEthernet
0/0/3
4.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
5.0.0.0/24 IBGP 255 2 RD 70.0.0.2 GigabitEthernet
0/0/0
10.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
20.0.0.0/24 EBGP 255 0 D 30.0.0.1 GigabitEthernet
0/0/3
30.0.0.0/24 Direct 0 0 D 30.0.0.2 GigabitEthernet
0/0/3
30.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/3
40.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
50.0.0.0/24 IBGP 255 0 RD 70.0.0.2 GigabitEthernet
0/0/0
60.0.0.0/24 Direct 0 0 D 60.0.0.1 GigabitEthernet
0/0/0
60.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 IBGP 255 0 RD 60.0.0.2 GigabitEthernet
0/0/0
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

 

  (贰)查看PE贰上的路由表项如下,
从结果看同PE一学习到的路由类似,凡是从Tiguan四上学到的都是eBGP类型,从PE壹学习到的都是IBGP类型,如下:

<Huawei>display ip routing-table

三、验证结果

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
2.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
5.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
10.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
30.0.0.0/24 IBGP 255 0 RD 60.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
50.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
60.0.0.0/24 Direct 0 0 D 60.0.0.2 GigabitEthernet
0/0/0
60.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 Direct 0 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

三、网络连通性验证

  (壹)从PC一 分别ping
PC2,PC3,PC四,结果彰显都能够ping通,表达整网是路由可到的。

PC>ping 4.0.0.10 -c 2

Ping 4.0.0.10: 32 data bytes, Press Ctrl_C to break
From 4.0.0.10: bytes=32 seq=1 ttl=122 time=265 ms
From 4.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 4.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/257/265 ms

PC>ping 2.0.0.10 -c 2

Ping 2.0.0.10: 32 data bytes, Press Ctrl_C to break
From 2.0.0.10: bytes=32 seq=1 ttl=125 time=109 ms
From 2.0.0.10: bytes=32 seq=2 ttl=125 time=141 ms

— 2.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 109/125/141 ms

PC>ping 5.0.0.10 -c 2

Ping 5.0.0.10: 32 data bytes, Press Ctrl_C to break
From 5.0.0.10: bytes=32 seq=1 ttl=122 time=282 ms
From 5.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 5.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/266/282 ms

PC>

  

  (二)从PC一上tracerout PC二, PC3,PC4,
可见沿途的路由器是没有错的,当然,不科学的话,网络就打断了。

PC>tracert 4.0.0.10

traceroute to 4.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 47 ms 31 ms 32 ms
2 10.0.0.1 62 ms 94 ms 47 ms
3 30.0.0.2 93 ms 94 ms 94 ms
4 60.0.0.2 109 ms 125 ms 125 ms
5 70.0.0.2 172 ms 219 ms 172 ms
6 40.0.0.2 219 ms 250 ms 234 ms
7 *4.0.0.10 234 ms 203 ms

PC>

PC>tracert 2.0.0.10

traceroute to 2.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 32 ms 31 ms 31 ms
2 10.0.0.1 94 ms 78 ms 63 ms
3 20.0.0.2 125 ms 125 ms 109 ms
4 *2.0.0.10 171 ms 157 ms

PC>

PC>tracert 5.0.0.10

traceroute to 5.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 31 ms 31 ms 31 ms
2 10.0.0.1 63 ms 62 ms 63 ms
3 30.0.0.2 94 ms 78 ms 94 ms
4 60.0.0.2 125 ms 125 ms 125 ms
5 70.0.0.2 187 ms 172 ms 156 ms
6 50.0.0.2 188 ms 203 ms 172 ms
7 *5.0.0.10 312 ms 313 ms

PC>

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 15 Routes : 15

Destination/Mask Proto Pre Cost Flags NextHop Interface

1.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
2.0.0.0/24 IBGP 255 2 RD 30.0.0.1 GigabitEthernet
0/0/0
4.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
5.0.0.0/24 EBGP 255 2 D 70.0.0.2 GigabitEthernet
0/0/2
10.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 IBGP 255 0 RD 30.0.0.1 GigabitEthernet
0/0/0
30.0.0.0/24 IBGP 255 0 RD 60.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
50.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
60.0.0.0/24 Direct 0 0 D 60.0.0.2 GigabitEthernet
0/0/0
60.0.0.2/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/0
70.0.0.0/24 Direct 0 0 D 70.0.0.1 GigabitEthernet
0/0/2
70.0.0.1/32 Direct 0 0 D 127.0.0.1 GigabitEthernet
0/0/2
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0

<Huawei>

3、互联网连通性验证

  (一)从PC一 分别ping
PC二,PC三,PC4,结果彰显都能够ping通,表明整网是路由可到的。

PC>ping 4.0.0.10 -c 2

Ping 4.0.0.10: 32 data bytes, Press Ctrl_C to break
From 4.0.0.10: bytes=32 seq=1 ttl=122 time=265 ms
From 4.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 4.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/257/265 ms

PC>ping 2.0.0.10 -c 2

Ping 2.0.0.10: 32 data bytes, Press Ctrl_C to break
From 2.0.0.10: bytes=32 seq=1 ttl=125 time=109 ms
From 2.0.0.10: bytes=32 seq=2 ttl=125 time=141 ms

— 2.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 109/125/141 ms

PC>ping 5.0.0.10 -c 2

Ping 5.0.0.10: 32 data bytes, Press Ctrl_C to break
From 5.0.0.10: bytes=32 seq=1 ttl=122 time=282 ms
From 5.0.0.10: bytes=32 seq=2 ttl=122 time=250 ms

— 5.0.0.10 ping statistics —
2 packet(s) transmitted
2 packet(s) received
0.00% packet loss
round-trip min/avg/max = 250/266/282 ms

PC>

  

  (二)从PC1上tracerout PC二, PC三,PC4,
可知沿途的路由器是科学的,当然,不正确的话,互连网就打断了。

PC>tracert 4.0.0.10

traceroute to 4.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 47 ms 31 ms 32 ms
2 10.0.0.1 62 ms 94 ms 47 ms
3 30.0.0.2 93 ms 94 ms 94 ms
4 60.0.0.2 109 ms 125 ms 125 ms
5 70.0.0.2 172 ms 219 ms 172 ms
6 40.0.0.2 219 ms 250 ms 234 ms
7 *4.0.0.10 234 ms 203 ms

PC>

PC>tracert 2.0.0.10

traceroute to 2.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 32 ms 31 ms 31 ms
2 10.0.0.1 94 ms 78 ms 63 ms
3 20.0.0.2 125 ms 125 ms 109 ms
4 *2.0.0.10 171 ms 157 ms

PC>

PC>tracert 5.0.0.10

traceroute to 5.0.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 1.0.0.1 31 ms 31 ms 31 ms
2 10.0.0.1 63 ms 62 ms 63 ms
3 30.0.0.2 94 ms 78 ms 94 ms
4 60.0.0.2 125 ms 125 ms 125 ms
5 70.0.0.2 187 ms 172 ms 156 ms
6 50.0.0.2 188 ms 203 ms 172 ms
7 *5.0.0.10 312 ms 313 ms

PC>

(一)平常景况下,从PC三 —> PC一 的路由,走CE2 —> CE 一 —> PE
一 —> PE叁  —-> CE3

六、总结

壹、分域使用那多少个措施达成了下落非宗旨路由器的路由表容量的渴求?

  解答:共使用3种措施,

  第贰、分域,域内使用OSPF,域间使用BGP。

  第1、域内通过OPF布告的默认路由,使得域内的路由器不须要掌握其余域的路由音信,只必要经过暗中认可路由,送给PE设备即可。

  第二、域间的大旨层使用eBGP知晓全数的明细路由,以便教导域间流量转载。

贰、遗留问题,怎么样安插让IGP的分界路由器的路由表体积也变小?

  福睿斯3、CR-V4作为多个自治域的边际路由器,通过eBGP知道了颇具的互联网路由,那么些对路由器的须求依然非常的大,有什么办法能够让那八个路由器只要求将无法转车的报文通过暗许路由转载即可。继续探究中

三、BGP的基本用途是怎样?

  解答:核心层设备接头全量路由,指引报文在域间转载。

 

六、总结

一、分域使用那几个措施实现了下落非主旨路由器的路由表容积的渴求?

  解答:共使用3种措施,

  第3、分域,域内使用OSPF,域间使用BGP。

  第壹、域内通过OPF通知的暗许路由,使得域内的路由器不须求知道别的域的路由音讯,只须要经过暗许路由,送给PE设备即可。

  第壹、域间的核心层使用eBGP知晓全体的明细路由,以便辅导域间流量转载。

2、遗留难点,怎么样安插让IGP的界限路由器的路由表容积也变小?

  大切诺基叁、R四作为多个自治域的界线路由器,通过eBGP知道了颇具的互联网路由,那么些对路由器的须求还是不小,有哪些办法能够让这四个路由器只要求将不能够转车的报文通过暗许路由转发即可。继续商讨中

3、BGP的基本用途是怎么着?

  解答:主旨层设备接头全量路由,指引报文在域间转载。

 

从PC三上查看路由:

PC>tracert 192.168.0.10

traceroute to 192.168.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 172.16.0.1 32 ms 15 ms 16 ms
2 100.0.0.2 47 ms 47 ms 62 ms
3 60.0.0.1 63 ms 78 ms 62 ms
4 40.0.0.2 125 ms 78 ms 94 ms
5 10.0.0.1 94 ms 109 ms 110 ms
6 192.168.0.10 156 ms 125 ms 156 ms

PC>

 

查阅此时CE二上路由音讯,可见下1跳是CE之间的IBGP路径。

ca88亚洲城网站 4

 

 

(二)优选路由故障景况下,走次选路由。从PC3 —> PC壹 的路由,走CE贰—> PE贰 —> PE 4 —> 奥迪Q5一 —> PE3  —-> CE3

格局链路故障:PE1 装备上关闭端口GE 0/0/叁(ip地址为 40.0.0.一).

从PC三上查看路由:

PC>tracert 192.168.0.10

traceroute to 192.168.0.10, 8 hops max
(ICMP), press Ctrl+C to stop
1 172.16.0.1 16 ms 15 ms 32 ms
2 70.0.0.1 31 ms 47 ms 47 ms
3 50.0.0.1 62 ms 63 ms 78 ms
4 30.0.0.1 109 ms 63 ms 93 ms
5 20.0.0.2 125 ms 94 ms 156 ms
6 10.0.0.1 157 ms 140 ms 157 ms
7 192.168.0.10 156 ms 172 ms 187 ms

PC>

 

查阅此时CE2上路由信息,可知下1跳是PE2之间的EBGP路径。

ca88亚洲城网站 5

 

(三)故障恢复生机后,路由回切到优选路由。

结果见(1) 

 

四、曾经现身的标题

(一)PE2和PE三之间,建立EBGP对等体战败。

原因:EBGP邻居只好建立在直连设备间,不可能跨设备建立EBGP邻居。

故此,先通过PE四和PE三建立IBGP对等体,然后在经过PE肆和PE二建立EBGP对等体,从而将PE三上的路由新闻告诉PE2。

 

(二)直连的设施不可能树立IBGP邻居。

缘由:1般景况下,大家会选择loopback ip作为BGP 的router id.
此时要专注,建立邻居时使用的peer 地址和那一个router id未有关联,此时peer
ip应当设置成直连设备之间的ip即可。

bgp 65001
router-id 60.0.0.1
peer 40.0.0.2 as-number 65001

 

(三)非直连的设备之间不能建立IBGP邻居。

难点现象:查看bgp
peer的景色,总是停在active状态,不可能抵达established状态。从BGP邻居的1端
ping 另

难点源于:BGP邻居的创立注重于TCP可达,非直连的邻居必须配备相同的TCP源ip和目标ip,才能创立。源ip正是connect-interface
的ip, 目标ip便是peer ip。

以PE3、PE4为例,

PE叁的配备如下:

bgp 65001
router-id 10.0.0.2
peer 30.0.0.2 as-number 65001
peer 30.0.0.2 connect-interface GigabitEthernet0/0/0     (说明: GigabitEthernet0/0/0 的ip地址=
20.0.0.2)

 

PE4的陈设如下:

bgp 65001
router-id 50.0.0.1
peer 20.0.0.2 as-number 65001
peer 20.0.0.2 connect-interface GigabitEthernet0/0/1  (说明: GigabitEthernet0/0/1
的ip地址= 30.0.0.2)

(四)OSPF学习的路由优先级比BGP高,导致首要选拔路由连接被OSPF协议优选。

1度出现的风貌,PE2、PE3准将BGP的路由引入到OSPF中,结酚酞致在PE一上查看
172.1陆.0.十 的路由下一跳为40.0.0.贰,
而依据BGP短的AS号路径的口气,下一跳应当是60.0.0.2.
停歇PE贰、PE三上BGP的路子引入BGP后,PE1上指标17二.1陆.0.10的下1跳符合预期。

依照设备手册上的叙述:当中,0象征一向连接的路由,255象征别的来源离谱源端的路由;数值越小申明优先级越高。

ca88亚洲城网站 6

 

 

伍、常用命令和调节命令。

(壹)怎么看出来有两条BGP路由,优选了AS号短的路线?

关键设备是CE二,也许CE1设备,查看那七个设备的bgp路由,能够看出有两条到达相同目标ip的路由,以CE2为例,

<CE2>dis bgp routing-table 192.168.0.10

BGP local router ID : 70.0.0.2
Local AS number : 65009
Paths: 2 available, 1 best, 1
select

BGP routing table entry information of 192.168.0.0/24:
From: 100.0.0.2 (60.0.0.2)
Route Duration: 00h12m53s 
Relay IP Nexthop: 100.0.0.2
Relay IP Out-Interface: Vlanif3
Original nexthop: 60.0.0.1
Qos information : 0x0
AS-path 65001 65005, origin igp,
localpref 100, pref-val 0, valid, internal, be

st, select, active, pre 255
Advertised to such 1 peers:
70.0.0.1
BGP routing table entry information of 192.168.0.0/24:
From: 70.0.0.1 (70.0.0.1)
Route Duration: 00h12m26s 
Direct Out-interface: Vlanif2
Original nexthop: 70.0.0.1
Qos information : 0x0
AS-path 65002 65001 65005, origin igp, pref-val 0, valid, external, pre
255, no
t preferred for AS-Path
Not advertised to any peer yet

<CE2>

 

(二)显示内定项目标商业事务学习的路由

<PE2>dis ip routing-table protocol ospf

Route Flags: R – relay, D – download to fib

Public routing table : OSPF
Destinations : 5 Routes : 5

OSPF routing table status : <Active>
Destinations : 5 Routes : 5

Destination/Mask Proto Pre Cost Flags NextHop Interface

10.0.0.0/24 OSPF 10 4 D 50.0.0.1 GigabitEthernet
0/0/0
20.0.0.0/24 OSPF 10 3 D 50.0.0.1 GigabitEthernet
0/0/0
30.0.0.0/24 OSPF 10 2 D 50.0.0.1 GigabitEthernet
0/0/0
40.0.0.0/24 OSPF 10 4 D 50.0.0.1 GigabitEthernet
0/0/0
60.0.0.0/24 OSPF 10 5 D 50.0.0.1 GigabitEthernet
0/0/0

OSPF routing table status : <Inactive>
Destinations : 0 Routes : 0

<PE2>

<PE2>dis ip routing-table protocol bgp

Route Flags: R – relay, D – download to fib

Public routing table : BGP
Destinations : 5 Routes : 5

BGP routing table status : <Active>
Destinations : 5 Routes : 5

Destination/Mask Proto Pre Cost Flags NextHop Interface

3.0.0.2/32 EBGP 255 0 D 50.0.0.1 GigabitEthernet
0/0/0
100.0.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
172.16.0.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
172.16.1.0/24 EBGP 255 0 D 70.0.0.2 GigabitEthernet
0/0/2
192.168.0.0/24 EBGP 255 0 D 50.0.0.1 GigabitEthernet
0/0/0

BGP routing table status : <Inactive>
Destinations : 0 Routes : 0

<PE2>

 

(三)展现BGP邻居新闻

<PE2>dis bgp peer

BGP local router ID : 70.0.0.1
Local AS number : 65002
Total number of peers : 2 Peers in established state : 2

Peer V AS MsgRcvd MsgSent OutQ Up/Down State Pre
fRcv

50.0.0.1 4 65001 183 315 0 02:26:04 Established
7
70.0.0.2 4 65009 161 187 0 01:21:57 Established
10
<PE2>

 

(肆)突显BGP路由详细音讯

 

<PE2>dis bgp routing-table

ca88亚洲城网站 7

ca88亚洲城网站 8

 

(伍)展现 路由表,显示钦定目的ip的路由音信。

<CE2>dis ip routing-table 

Route Flags: R – relay, D – download to fib

Routing Tables: Public
Destinations : 17 Routes : 17

Destination/Mask Proto Pre Cost Flags NextHop Interface

3.0.0.2/32 IBGP 255 0 RD 60.0.0.1 Vlanif3
10.0.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3
20.0.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3
30.0.0.0/24 EBGP 255 2 D 70.0.0.1 Vlanif2
40.0.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3
50.0.0.0/24 EBGP 255 0 D 70.0.0.1 Vlanif2
60.0.0.0/24 IBGP 255 0 RD 100.0.0.2 Vlanif3
70.0.0.0/24 Direct 0 0 D 70.0.0.2 Vlanif2
70.0.0.2/32 Direct 0 0 D 127.0.0.1 Vlanif2
100.0.0.0/24 Direct 0 0 D 100.0.0.1 Vlanif3
100.0.0.1/32 Direct 0 0 D 127.0.0.1 Vlanif3
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
172.16.0.0/24 Direct 0 0 D 172.16.0.1 Vlanif1
172.16.0.1/32 Direct 0 0 D 127.0.0.1 Vlanif1
172.16.1.0/24 IBGP 255 0 RD 100.0.0.2 Vlanif3
192.168.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3

<CE2>

 

展示钦定指标ip的优选路由

<CE2>dis ip routing-table 192.168.0.10 

Route Flags: R – relay, D – download to fib

Routing Table : Public
Summary Count : 1
Destination/Mask Proto Pre Cost Flags NextHop Interface

192.168.0.0/24 IBGP 255 0 RD 60.0.0.1 Vlanif3

<CE2>

 

 

(伍)定位BGP不可能建立的通令

<PE2>debug bgp 50.0.0.1 all
<PE2>t d
Info: Current terminal debugging is on.
<PE2>t m
Info: Current terminal monitor is on.
<PE2>sys
Enter system view, return user view with Ctrl+Z.
[PE2]info enable
Info: Information center is enabled.
[PE2]

 

 陆、关键配置

CE3设备配备:

#
bgp 65005
router-id 10.0.0.1
peer 拾.0.0.二 as-number 6500壹              (与营业商PE之间确立 EBGP
邻居)
#
ipv4-family unicast
undo synchronization
network 10.0.0.0 255.255.255.0
network 192.168.0.0
peer 10.0.0.2 enable
#

 

PE3设备配置:

#
bgp 65001
router-id 10.0.0.2
peer 10.0.0.一 as-number 65005                                 
 (与客户CE之间建立 EBGP 邻居)
peer 20.0.0.一 as-number 65001                                 
 (与运行商PE之间创建 IBGP 邻居)
peer 30.0.0.2 as-number 65001
peer 30.0.0.2 connect-interface GigabitEthernet0/0/0
peer 40.0.0.1 as-number 65001
peer 50.0.0.二 as-number 6500二                                  (与运维商PE之间建立 EBGP 邻居)
peer 50.0.0.2 connect-interface GigabitEthernet0/0/1
#
ipv4-family unicast
undo synchronization
network 3.0.0.1 255.255.255.255
network 10.0.0.0 255.255.255.0
network 20.0.0.0 255.255.255.0
network 40.0.0.0 255.255.255.0
peer 10.0.0.1 enable
peer 20.0.0.1 enable
peer 30.0.0.2 enable
peer 40.0.0.1 enable
peer 50.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
network 40.0.0.0 0.0.0.255
#

 

奥迪Q51设备配置:

#
bgp 65001
router-id 20.0.0.1
peer 10.0.0.2 as-number 65001
peer 30.0.0.2 as-number 65001
peer 50.0.0.2 as-number 65001
peer 50.0.0.2 connect-interface GigabitEthernet0/0/0
#
ipv4-family unicast
undo synchronization
network 20.0.0.0 255.255.255.0
network 30.0.0.0 255.255.255.0
peer 10.0.0.2 enable
peer 30.0.0.2 enable
peer 50.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 20.0.0.0 0.0.0.255
network 30.0.0.0 0.0.0.255
#

 

PE四设备配置:

#
bgp 65001
router-id 50.0.0.1
peer 20.0.0.2 as-number 6500一          (与营业商PE之间创造 IBGP 邻居)
peer 20.0.0.2 connect-interface GigabitEthernet0/0/1
peer 30.0.0.一 as-number 6500一          (与营业商PE之间创建 IBGP 邻居)
peer 50.0.0.二 as-number 6500二          (与运转商PE之间确立 EBGP 邻居)
#
ipv4-family unicast
undo synchronization
network 30.0.0.0 255.255.255.0
network 50.0.0.0 255.255.255.0
peer 20.0.0.2 enable
peer 30.0.0.1 enable
peer 50.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 30.0.0.0 0.0.0.255
network 50.0.0.0 0.0.0.255
#

 

PE二设备配置:

#
bgp 65002
router-id 70.0.0.1
peer 50.0.0.1 as-number 6500壹             (与运转商PE之间创立 IBGP 邻居)
peer 70.0.0.2 as-number 6500九             (与客户CE之间确立 EBGP 邻居)
#
ipv4-family unicast
undo synchronization
network 50.0.0.0 255.255.255.0
network 70.0.0.0 255.255.255.0
peer 50.0.0.1 enable
peer 70.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 50.0.0.0 0.0.0.255
network 70.0.0.0 0.0.0.255
#

 

CE二设备配备:

#
bgp 65009
router-id 70.0.0.2
peer 70.0.0.一 as-number 6500贰              (与营业商PE之间创造EBGP邻居)
peer 拾0.0.0.二 as-number 6500九           
(与同级设备建立IBGP邻居)
#
ipv4-family unicast
undo synchronization
network 70.0.0.0 255.255.255.0
network 100.0.0.0 255.255.255.0
network 172.16.0.0 255.255.255.0
peer 70.0.0.1 enable
peer 100.0.0.2 enable
#

 

PE一设备配备:

#
bgp 65001
router-id 60.0.0.1
peer 40.0.0.2 as-number 6500壹           (与营业商PE之间建立 IBGP 邻居)
peer 60.0.0.二 as-number 6500玖           (与客户CE之间创建 EBGP 邻居)
#
ipv4-family unicast
undo synchronization
network 40.0.0.0 255.255.255.0
network 60.0.0.0 255.255.255.0
peer 40.0.0.2 enable
peer 60.0.0.2 enable
#
ospf 1
area 0.0.0.0
network 40.0.0.0 0.0.0.255
network 60.0.0.0 0.0.0.255
#

 

CE1设备配置:

#
bgp 65009
router-id 60.0.0.2
peer 60.0.0.一 as-number 6500一                (与运转商PE之间建立EBGP邻居)
peer 拾0.0.0.壹 as-number 6500玖             
(与同级设备建立IBGP邻居)
#
ipv4-family unicast
undo synchronization
network 60.0.0.0 255.255.255.0
network 172.16.1.0 255.255.255.0
peer 60.0.0.1 enable
peer 100.0.0.1 enable
#

相关文章